SQLDirect Component Library 5.1

SQLDirect Component Library is a light-weight Borland Database Engine replacement for Borland Delphi v.4 - 10(2006) and C++Builder v.4 - 6, 2006. It uses the native application programming interfaces to access to the following SQL-servers:

* Centura (formerly, Gupta) SQLBase Server
* IBM DB2 Universal Database
* Informix Server
* Interbase/Firebird Server
* Microsoft SQL Server
* MySQL Server
* Oracle Database Server
* PostgreSQL Server
* Sybase Adaptive Server Enterprise and Adaptive Server Anywhere
* ODBC datasources
* OLEDB datasources

Using of SQLDirect Component Library gives you the following advantages:

  • connecting to the following SQL servers using 32-bit native application programming interfaces (API): Centura SQLBase Server 6(+), IBM DB2 Universal Database with CAE v5.2, Informix Server 7.2(+), Firebird, Interbase, MySQL 3.23(+), Oracle Server 7.2(+) with SQL*Net 2.2(+), Microsoft SQL Server, PostgreSQL 7.1(+), Sybase Adaptive Server Enterprise and Adaptive Server Anywhere (through Open Client, which is supported by Anywhere ver.6 as native interface), ODBC and OLEDB datasources.
  • no distributing, installing and configuring the BDE or ODBC
  • simultaneous access to the supported servers
  • using Delphi 4, 5, 6, 7, 8, 9(2005), 10(2006) or C++Builder 4, 5, 6, 2006 (Pro and above) to develop Client/Server applications
  • query with an updatable result set
  • query with macro support
  • table component
  • thread safe
  • BLOB-fields (including LOB and BFILE for Oracle8)
  • stored procedure support (with mutiple result sets for IBM DB2, Microsoft and Sybase SQL Server)
  • bi-directional and unidirectional result sets
  • cached updates
  • record filtering
  • support of data-aware components
  • InfoPower support
  • using images stored by Centura SqlWindows(or Team Developer) in their proprietary format
  • interfaces (public methods and properties) of SQLDirect components are compatible with standard BDE data access components (TSession, TDatabase, TQuery ..).

Thread Safety Note

        Thread safety is supported by the following software:

  • Oracle SQL*Net 2.3 or above
  • Centura SQLBase Ver. 7 or above
  • IBM DB2 Ver. 5.2 or above
  • Microsoft SQL Server Ver. 6 or above
  • Sybase ASE and ASA through OpenClient Ver. 11.1 or above

 



Опубликовал admin
24 Июл, Понедельник 2006г.



Программирование для чайников.