Использование изученных ранее методов

Давайте попытаемся определить сумму, потраченную всей семьей за период с 5 по 15 февраля. Это можно сделать двумя методами.
- Во-первых, можно, выделив на рабочем листе ЖурналРегистрации строки 2:27, нажать на стандартной панели инструментов кнопку Сортировка по возрастанию, после чего, активизировав, например, ячейку В30, нажать кнопку Автосумма стандартной панели инструментов и выделить на рабочем листе диапазон С5:С16. Полученная в результате формула будет иметь вид:

=СУМM(С5:С16)

В случае изменения данных операцию необходимо будет повторить.
- Во-вторых, можно создать на отдельном листе таблицы с формулами и производить нужные расчеты с их помощью.

Рассмотрим подробнее второй метод. Перейдите на лист Лист1 и сформируйте в первых двух строках шапку таблицы, как показано на рис. 9.11. В ячейки A3 и С3 занесите даты.

Теперь мы перенесем из журнала регистрации данные, которые относятся к интересующему нас периоду. В первую очередь необходимо определить записи, у которых в столбце А журнала регистрации дата равна или больше даты, указанной в ячейке A3 (то есть 5 февраля). Для этого занесите в ячейку А4 следующую формулу:

=ЕСЛИ(ЖурналРегистрации!А2>=$А$3;1;0)

Она работает следующим образом. Если условие соблюдается, формула выдает значение 1. Если условие не соблюдается, то будет выдано значение 0.

Содержимое ячейки А4 анализируется формулой в ячейке В4. Если в ячейке А4 содержится 1, то ячейка В4 должна возвратить значение, находящееся в соответствующей ячейке столбца С (расходы) листа ЖурналРегистрации. Таким образом, формула в ячейке В4 будет имеет вид

=ЕСЛИ(А4=0;0;ЖурналРегистрации!С2)

В столбце С листа Лист1 проводится анализ даты, указанной в столбце А листа ЖурналРегистрации. Здесь проверяется, является ли она меньшей или равной дате, указанной в ячейке СЗ. Поэтому ячейка С4 содержит такую формулу:

=ЕСЛИ(ЖурналРегистрации!А2<=$С$3;1;0)

Формулы в столбце D аналогичны формулам в столбце В. В частности, ячейка D4 содержит следующую формулу:

=ЕСЛИ(С4=0;0;ЖурналРегистрации!С2)

В столбце Е проверяется, выполняются или нет условия в формулах столбцов А и С. Если да, то в ячейке Е4 отражается значение, указанное в ячейке D4. Формула имеет вид:

=ЕСЛИ(А4+С4=2;D4;0)

Далее в ячейке ЕЗ происходит суммирование всех отобранных предыдущими формулами значений. В ячейке ЕЗ будет такая формула:

=СУММ(Е4:Е1000)

На рис. 9.11 приведен рабочий лист с числовым примером решения данного задания, а на рис. 9.12 - с формулами.

Поставленную в начале этого раздела задачу можно решить, если далее проводить сравнения со словами: "Мать", "Обувь" и "Летняя", а затем вложить одну формулу в другую. Поскольку журнал регистрации может включать сотни строк, то сотни таких формул займут много места и значительно снизят быстродействие программы. Избежать этой проблемы позволяют формулы массива.

Рис. 9.11. Рабочий листе числовым примером

Рис. 9.12. Рабочий лист с формулами вычисления



Опубликовал admin
31 Июл, Понедельник 2006г.



Программирование для чайников.